Upgrading to a new version

Make sure that your opam is in version 2

The last version of Dep2pict requires that the opam tool is in version 2.0.0 or higher.

You can check your versions with the command opam --version. It it’s not version 2, re-install opam in version 2 with instructions steps 2 and 3 on the Installation page.

Update the Dep2pict software

opam update
opam upgrade

Update the Qt GUI

pip install dep2pict-gui --upgrade

Check Pypi page for info about the last version.